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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

¢ Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

» Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

« On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click Maxwell 3D > Excitations > Assign > Wave Port.”

» Labeled keys on the computer keyboard. For example, “Press Enter’ means to
press the key labeled Enter.

« ltalic type is used for the following:
* Emphasis
 Titles of publications

« Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

» The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can

be used to see what commands are available in the application.

* The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

@ A |
O L.
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

* The menu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

¢ Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation > Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:
* [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.

» [product name] Scripting Help - opens the contents of the Scripting Guide.

» [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction

This Getting Started Guide is written for Maxwell beginners and experienced users who would
like to quickly refamiliarize themselves with the capabilities of Maxwell. This guide leads you
step-by-step through solving and analyzing the results of a rotational actuator magnetostatic
problem with motion.

By following the steps in this guide, you will learn how to perform the following tasks:

» Modify a model’s design parameters

» Assign variables to a model’s design parameters
» Specify solution settings for a design

» Validate a design’s setup

* Run a Maxwell simulation

» Plot the magnetic flux density vector

¢ Include motion in the simulation

Note: This guide assumes that you have already completed the magnetostatic
example in Getting Started with Maxwell: Designing a Rotational Actuator. If you have
not, you may use the project archive in the example directory; however, it is strongly
recommended that you complete the magnetostatic example.

Maxwell Solution Types

Ansys Maxwell is an interactive software package that uses finite element analysis (FEA) to
simulate (solve) electromagnetic field problems. Maxwell integrates with other Ansys
Electromagnetic software to perform complex tasks while remaining simple to use. Maxwell
incorporates a set of 2D and 3D solvers in the Ansys Electronics Desktop integrated user
interface. This guide will focus on 3D capabilities. A 2D problem example is covered in a
separate Getting Started Guide.

The following six types of stand-alone solutions are supported by Maxwell 3D:

» Magnetostatic linear and nonlinear 3D fields caused by a user-specified distribution of
DC current density and permanent or externally applied magnetic fields. Materials can be
nonlinear and anisotropic. Additional quantities that can be computed include torque,
force, and self and mutual inductances.

+ Harmonic (sinusoidal variation in time) steady-state magnetic fields with pulse-
induced eddy currents in massive solid conductors caused by one of the following:

» A user-specified distribution of AC currents (all with the same frequency but with
possibly different initial phase angles).

Introduction 1-1
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» Externally applied magnetic fields.

This solution includes displacement currents for calculating near field electromagnetic
wave radiation.

« Transient (time domain) magnetic fields caused by permanent magnets, conductors,
and windings supplied by voltage and/or current sources with arbitrary variation as
functions of time. Rotational or translational motion effects can be included in the
simulation. This option uses the TAU solver.

* A-Phi Formulation: This solver is an alternative to the transient TAU solver. A is
the Magnetic Vector Potential and ¢(Phi) is the Electric Scalar Potential. The A-Phi
solver allows multi-terminal conductors, and it supports sources of various types on
a single conduction path; the J and E fields are calculated directly becauseitis a
first-order approximation. This option is useful for application fields in Power
Electronics, Bus Bars, PCBA, etc., where the voltage distribution in multiple
conductors is essential.

« Electrostatic 3D fields caused by a user-specified distribution of voltages and charges in
nonconducting regions. Additional quantities that can be computed include torque, force,
and capacitances.

» Electric DC conduction 3D fields in conductors characterized by a spatial distribution of
voltage, electric field, and current density. Power loss can also be computed. In addition,
optional simulation of fields in insulating materials is supported.

+ Transient (time domain) 3D electric fields caused by time dependent voltage, current
and charge distributions. All sources are arbitrary functions of time.

* AC Conduction 3D electric fields and losses arising in conductors and imperfect (lossy)
dielectrics from the application of an alternating (AC) voltage or external current to the
electrodes. The AC conduction field solver assumes that all sources are sinusoids
oscillating at the same frequency.

In addition, Maxwell may be coupled with other simulators to provide a greater range of solution
capability. Couplings to Workbench for thermal and stress analysis, HFSS for ferrite analysis,
and Twin Builder for Finite Element/Circuit cosimulation are all supported.

The Maxwell Desktop

The following graphic shows the different sections of the Maxwell desktop:
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Project Manager a x E--f@ Model
- Rotational_Act_TR* 2-&7 Solids
2§ Rotational_Act_TR1 (Tran o arm _steel
é 30 Components 9 Inner_arm
[].._f@ Model M- Outer_arm
% Boundaries Es copper
-2 Excitations @ coill
-G Parameters E-&7 coill_1
B8 Mesh Eg vacuum
[]...ﬁ Analysis @ Air_rotor
@ Optimetrics @ Band
#-FF Results B-&7 Bgnd
[]---ﬁ Field Overlays H-E3 Sheets
..... |2 Notes m-l, Coordinate Systems
-2 Definitions =-&# Planes
- Lists
£ >
Properties a x

General Procedure for Setting Up Maxwell Designs

You are not required to follow a specific order when setting up your Maxwell design. However,
the following order is recommended, particularly for new users:

. Open Ansys Electronics Desktop by double-clicking the desktop icon or by clicking Start >

Programs > Ansys EM Suite [version] > Ansys Electronics Desktop [version] from
the Windows taskbar.

Add a Maxwell 3D design and save the new project.
Draw the geometry of the model.

Optionally, modify the model's design parameters.
Assign variables to design parameters.

Assign excitations and boundary conditions.
Specify solution settings.

Run a Maxwell simulation.

Create post-processing plots.

Create a parametric analysis.

. Create a field animation of the parametric analysis results.
. Include motion in the transient design.

Introduction 1-3
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About the Example Design

The application described in this Getting Started guide is an extension of the design created in
Getting Started with Maxwell: Designing a Rotational Actuator. The geometry is shown below:

Axial length (rotor and stator) = 25.4

@ 1021

& 2090

Coils

The outer part is a nonlinear, ferromagnetic armature carrying two coils. The inner part is made
of the same nonlinear material and can rotate around an axis. The inner and outer parts of the
device are coaxial.

The field distribution will likely cause the flux density to concentrate in the two steel armatures in
the regions where the distance between them is minimal. The expected edge effect will then
further increase the field concentration.

In this example, we will compute the torque acting on the inner armature and the flux linkage of
the two coils. Simulation results show a 3D electromagnetic time-transient problem with the
effects of large motion included. Both the rotor and stator are made of solid ferromagnetic steel,
creating significant eddy current effects. A nonlinear B-H curve is considered for the stator and
rotor steel. The solution includes the estimated mechanical rotor inertia. For a presentation of
the results and the corresponding FEM code, see the IEEE Transactions on Magnetics, Vol 38,
No. 2, March 2002, pp 609-612.

Introduction 1-4
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2 - Setting Up the Design

In this chapter, you will complete the following tasks:

+ Open and save a new project

¢ Insert a new Maxwell design into the project

» Select a solution type for the project

« Set the drawing units for the design

Open and Save a New Project

A project is a collection of one or more designs that is saved in a single *.aedt file. A new project
is automatically created when Ansys Electronics Desktop is launched.

To create a new Maxwell 3D design project:

1.

On Windows, click Start > Ansys EM Suite 2025 R2 Ansys Electronics Desktop 2025
R2.

On Linux, from the command line, cd to your /v252/AnsysEM/ directory, and enter
./ansysedt

Click Project > Insert Maxwell 3D Design.

The new design is listed in the Project Manager tree. By default, it is named
Maxwell3DDesign1. The Modeler window appears to the right of the Project Manager
window.

Click File > Save As.
The Save As dialog box appears.

Locate and select the folder in which you want to save the project.
Type Rotational_Act_TR in the File name box, and click Save.

The project is saved in the specified folder under the name Rotational_Act_TR.aedt.

Rename the design:
a. Right-click Maxwell3DDesign1.

A shortcut menu appears.

b. Select Rename.
The design name becomes highlighted and editable.

c. Type Rotational_Act_TR as the name for the design, and press Enter. The project

Setting Up the Design 2-1
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and design are now both named Rotational_Act_TR.

Project Manager
=[] Rotational_act_TR* -3 Sheets
@ Rotational_Act_TR {Transient) Lﬁ. Coordinate System
|:| Definitions "E‘ Planes
458 Lists

Specify a Solution Type

As mentioned in the introduction, multiple solution types are available, depending on the specific
application. For this design, choose a Transient solution.

To specify the solution type:
1. Click Maxwell 3D > Solution Type.
The Solution Type dialog box appears.

Solution Type: Rotational_Act_TR - Rotational_Act TR

b agretic Electric
" Magnetostatic " Electrostatic
" AC Magnetic [Eddy Current) " DC Conduction
r o
{* Tranzient " Electric Transient

" AC Conduction
Formulation:

& T-Omega © AFhi

ok | Cancel |

2. Select the Transient radio button. Leave the formulation to the default T-Omega.
3. Click OK.

Set the Drawing Units

To set the drawing units:
1. Click Modeler > Units.

The Set Model Units and Max Extent dialog box appears.

Setting Up the Design 2-2
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tor Set Model Units and Max Extent x
Select units: -

[T Rescale to new units

[T Advanced

Model extents: -10000 to 10000 rmm

All geometry should fit within these axtents,

[ ok | Cancel |

2. Select mm from the Select units drop-down menu.
3. Click OK.
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3 - Importing the Geometric Model

In this chapter you will open the Magnetostatic Getting Started project, copy the objects
definitions and material properties, and paste the objects and materials into the Rotational_
Act_TR transient project.

If you have not completed the magnetostatic guide Getting Started with Maxwell: Designing a
Rotational Actuator, it is strongly recommended that you do so to gain necessary knowledge of
modeling and material assignment principles. You may, however, use the project in the example
directory.

In this chapter you will complete the following tasks:
* Open the Magnetostatic Getting Started example.
» Copy and paste geometry and materials to the current project.

Open the Magnetostatic Project

The geometry and materials used in this project are identical to the magnetostatic guide
Rotational_Actuator project.

To open the magnetostatic project:
1. Click File > Open Examples.
The Windows file browser opens to the Examples folder installed with your application.

2. Locate the Maxwell\Actuators folder containing the Rotational_actuator.aedt project
from the magnetostatic guide, Getting Started with Maxwell: Designing a Rotational
Actuator.

3. Select the file Rotational_actuator.aedt and click Open.

The project is opened and is now listed in the Project Manager Window as shown.

Copy and Paste Objects between Projects

The ability to copy and paste objects and their associated material assignments is a useful and
time-saving function of the Ansys Electronics Desktop software.

In order to copy objects, all objects must be selected.

1. With the Rotational_actuator project in the modeler window, click in the modeler window
and then click Edit > Select All to select all object regardless of their visibility status.

The history tree\Model entry will expand and highlight all objects in the design.
2. Click Edit > Copy to copy the object and material definitions to the clipboard.

Importing the Geometric Model 3-1
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switch the Modeler window to the transient project.

keyboard shortcut Ctri-D.

Your screen should look approximately like the one below.

Click on the Rotational_Act_TR(Transient) design in the Project Manager window to

Click Edit > Paste to paste all objects and material definitions into the transient project.
Click View > Fit All > All Views to fit the objects to the window. You may also use the

In the Project Manager window, select the magnetostatic project Rotational_Actuator
and click File > Close.

Project Manager
=[] Rotational_Act_TR*

&5 3D Components

& Model

&¥ Boundaries

&Y Excitations

% Parameters

8 Mesh

5 Analysis

& optimetrics

) Results

T Field Overlays
®-_ Definitions

a

=80 Rotational_Act_TR (Transient)*

* 8 5 Model
=& Solids
- 4% arm_steel
«-4% copper
- S vacuum
-5 Sheets
&= Unassigned
=3 Section1
&% SectionFrom
¥ SeparateBody
=03 Section2
@& SectionFrom
# SeparateBody
#-la Coordinate Systems
-8 Planes
=€ Lists

: =

400 (rm)

7. Click File > Save to save the model before moving on to the next chapter.
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4 - Defining the Design Properties

For the transient problem, you want to use a pulse excitation to drive the coils. In order to
accomplish this, you will assign a external current winding excitation to the coils and use the
Maxwell Circuit Editor to create the external driving circuit including a pulse source. You will also
allow the software to calculate the eddy currents in the solid metal objects in the model.

In this chapter you will complete the following tasks:

« Verify material properties

« Assign excitations

« Set up an external circuit for the current winding
» Set up the mesh operations

Specify the eddy effect

Verify Material Properties

Material properties are automatically transferred when you copied the geometry objects. You
can view these properties by viewing the Attribute tab of the Properties window.

To verify the nonlinear material for the armatures:

1. Expand the Model\Solids entry in the history as shown.

=5 Solids

. -48F arm_steel
@£ inmer_arm
-7 R
-4 copper
- E-€P coill
 EEP coill_d
-4 vacuum

: -7 bgnd

-3 Sheets

. -3 Sectionl

- Section?

1, Coordinate Systems

= Planes

&

Lisks

I+

1+

2. Double-click the Outer_arm object.
The Properties window appears.

3. Inthe Material row, click the button in the Value column labeled arm_steel, then click
Edit.

Defining the Design Properties 4-1
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: Transient Problem

The Select Definition dialog box appears.
4. Click the View/Edit Material button.
The View/Edit Material dialog box appears.

5. Inthe Relative Permeability row, click the B-H Curve button.

The BH Curve dialog box appears as shown.

BH Curve a X
Temperatune |.-1II j Swap -1 Data J Import Datazet | Export Datased. . |
= Normal " Inrinsi
orm s arm_steel
Cootdinates
a7s ] —
H (A_per_meter) | Btesla) |~ ] I ———

0 ] . -
|| 4000 1.413 5 250 - —— .

_%10 1.594 E ::/-- -
men 1.751 @ b
1.25 =

24020 1.839 ]

32050 1.896 ]

40030 1.9% 0.00 T S S S
(48040 1967 0.00E+00 2.00E+05 4,00E+05 6.00E+05 8.00E+05 1.00E+06 1.20E406
| |e4080 2008 H (A_per_meter)

80070 2042

| | Intercept H [[ IA_DEl_I'neber 3 Recoil-Line Relative Peimeability 1
Append Rows. .. I |
Intercept B [ [tesla =
oK | Concel | |

6. Click Cancel in the BH Curve dialog box to close.

7. Continue dismissing dialog boxes until you have returned to the Modeler window.

Define the Currents

To define the currents:

1. Select Section1 and Section 2 under the Sheets entry in the history tree.

2. Click Maxwell 3D > Excitations > Assign > Coil Terminal.

The Coil Terminal Excitation dialog box appears.

3. Type 350 in the Number of Conductors box.
4. Click OK.

Defining the Design Properties 4-2
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Assign Excitations

Currents need to be defined and assigned as excitations for the two coil terminals.

Add a Winding

To add a winding for the excitation:
1. Click Maxwell 3D > Excitations > Add Winding.
The Winding dialog box appears.

Type currentwinding in the Name box (the default is Winding1).
Set the Type to External.

Select the Stranded radio button.

Leave the Initial Current set to the default value of 0 (zero).

o oD

Note: We are using an external circuit to supply the excitation to the coil. For this
example, we also could have used a voltage type of excitation.

6. Click OK.

Add a Winding Terminal

To add a terminal for the winding:
1. Inthe Project Manager tree, under Excitations, right-click currentwinding.
A shortcut menu appears.
2. Select Add Terminals from the shortcut menu.
The Add Terminals dialog box appears.

3. Inthelist, select CoilTerminal_1, press and hold down the Shift key, and select
CoilTerminal_2.

4. Click OK.

In the Project Manager tree, the two terminals are moved beneath the winding as shown

Defining the Design Properties 4-3
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below.
Project Manager a x
£ Rotational_Act_TR* A

EI@ Rotational_Act_TR (Transient)
é 3D Components

- Boundaries
E-#4 Excitations
=-{l]]| currentwinding

----- A4 CoilTerminal_1

----- 24 CoilTerminal_2

- Parameters

[-B8 Mesh

- Analysis

@ Optimetrics

----- Results iy

Properties 1 X

Name | Value | Unit |Eva|uated‘\u’...

Name currentwinding

Type Winding Group

Winding... External

IsSolid | Stranded

Initial Cu... 0 mA  OmA
Number .../ 1 1

Boundary Conditions

The region box (Bgnd) by default has all faces assigned with magnetic flux tangent boundary
conditions. Thus, for this problem no additional boundary conditions are needed.

Set Up the External Circuit

The driving circuit for the winding in this design consists of a voltage source in series with a
resistor and with the winding. When complete, the circuit should look similar to the following
figure:

Defining the Design Properties 4-4
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Add the Circuit Elements

To add the circuit elements in Maxwell Circuit Editor:
1. Click Project > Insert Maxwell Circuit Design.

The Maxwell Circuit Editor opens with a default circuit sheet as shown below.

Ansys Electronics Desktop 2025 R2 - Rotational_Act_TR - MaxCirl - SchematicEditor - [Rotational_Act_TR - MaxCirl - Schematic]
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2. Click the Components tab in the Component libraries window.
3. Place the winding circuit element on the sheet:

Defining the Design Properties 4-5
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Maxwell®: Transient Problem

f.
g.

In the Component Libraries tree, under Maxwell Circuit Elements/Dedicated
Elements, select the Winding element.

Click on, and drag the Winding element onto the sheet.

Right-click in the Schematic window, and select Finish to exit component
placement mode.

To view the properties, double-click the component in the Schematic window.
The Properties window appears.

Change the Name to currentwinding, the same name you used when defining the
winding in the Maxwell design.

Click OK.
Click Draw > Rotate, and position the winding vertically.

4. Place a resistor on the sheet:

a o T

In the Component Libraries tree, under Passive Elements, select Res:Resistor.
Drag the resistor onto the sheet.
Right-click, and select Finish to exit placement mode.

Double-click the symbol of the resistor, change the value of the resistor, R, to 3.09,
keep the Unit value set to ohm, and click OK.

5. Place a voltage pulse on the sheet:

a.

d.

In the Component Libraries tree, under Sources select a VPulse element (Pulse
Voltage Source).

Drag it to the sheet, and then right-click and select Finish.

Double-click the source element symbol on the sheet, and then specify the following
source characteristics:

Parameter | Value | Description

V1 0 Initial voltage

V2 5.97 Peak voltage

Td 0 Initial delay
time

Tr 0.001 Rise time

Tf 0.001 Fall time

Pw 1 Pulse width

Period 2

Leave the other fields set to the default values, and click OK.

Connect the Circuit Elements in Series

To connect the circuit elements in series:
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1. From within the Maxwell Circuit Editor, click Draw > Wire.
2. Click one terminal of the inductor and draw the wire to one resistor terminal as shown.

E‘I
|

3.0%chm [&]
% RE |
. = o
I 5.97V
[ E LabellD=v4
 E 5

3. Repeat until a closed circuit is formed.

Note: For the current winding, the “dotted” terminal is positive and current is
positive when it flows from the “dotted” terminal to the “undotted” terminal.
Connecting the winding as shown results in negative current in the plot in the
Create a Current vs Time Plot chapter. You may reverse the winding orientation
with no change to the problem except for the plot, which would show positive
currentin that case.

4. When done, place the Ground symbol:
a. Click Draw > Ground.

b. Place the Ground symbol on the sheet as shown below, right-click, and select
Finish.

2.09chm
RE

+ Label D=7
58TV
o

Lcurrentwinding

Export the Netlist

To export the netlist:
1. From within the Maxwell Circuit Editor, click Maxwell Circuit > Export Netlist.

The Netlist Export dialog box appears.
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2. Select the folder where you want to save the external circuit file.
3. Type trans_circ in the File name box.
4. Click Save to save the trans_circ.sph file.

The Netlist Export dialog box closes and the Maxwell Circuit Editor reappears.

Save the Maxwell Circuit Design

To save the Maxwell Circuit design:

1. Right-click the circuit design in the Project Manager tree, select Rename on the context
menu, and enter ExternalCircuit as the name.

2. Click File > Save to save the project with the new circuit design.

Assign the External Circuit

To assign the circuit in Maxwell:
1. Click Maxwell 3D > Excitations > External Circuit > Edit External Circuit.
The Edit External Circuit dialog box appears.
2. Click Import Circuit Netlist.
The Select File dialog box appears.

3. Select Maxwell Circuit Netlist Files (*.sph) from the Files of type drop-down menu.

4. Browse to the location where you saved the circuit, select trans_circ.sph, and click Open
to import it.

5. Click OK to close the Edit External Circuit dialog box.

Set Up Mesh Operations

This example involves transient magnetic fields in the presence of massive (solid) conductors,
resulting in eddy currents. To catch the effects with reasonable accuracy, a finer mesh is
required in those objects because skin effects are part of an accurate transient solution.

To seed the mesh to the desired density in the Outer_arm and Inner_arm objects:

1. Select Outer_arm from the history tree, press and hold down Ctrl, and then select Inner_
arm.

2. Click Maxwell 3D > Mesh > Assign Mesh Operation > Inside Selection > Length
Based.

The Element Length Based Refinement dialog box appears.

3. Type 10 in the Maximum Length of Elements box, and select mm as the units.
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4. Leave the Maximum number of additional elements check box unchecked.
5. Click OK.

This operation refines the mesh at run-time before the transient problem solution begins. This
mesh will be used for all time steps; therefore, the mesh density should be appropriate for the
anticipated field behavior for the entire transient analysis.

Specify the Eddy Effect Calculation

Eddy effects can be calculated in objects with non-zero electric conductivity.
To calculate eddy effects:
1. Click Maxwell 3D > Excitations > Set Eddy Effects.
The Set Eddy Effect dialog box appears.

2. Select the check boxes for the Inner_arm and Outer_arm objects.
3. Click OK.

Specify Torque Calculations

To set up the torque calculation:

1. Select the Inner_arm object in the history tree.
2. Inthe Project Manager tree, right-click Parameters row.

A shortcut menu appears.
3. Select Assign > Torque from the shortcut menu.
The Torque dialog box appears.

4. Select Global:Z from the Axis drop-down list.
5. Select the Positive radio button for the axis orientation.
6. Click OK.
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5 - Setting Up and Running the Analysis

In this chapter you will complete the following tasks:
e Setup the analysis
¢ Run and solve the analysis

Set Up the Analysis

To set up the analysis:
1. Right-click Analysis in the Project Manager tree, and select Add Solution Setup.
The Solve Setup dialog box appears.

Click the General tab.
Type 0.04 in the Stop time box, and select s as the unit.
Type 0.005 in the Time step box, and select s as the unit.

o bk~ wn

To save fields during the solution:
a. Click the Save Fields tab.
b. Select Custom. A row is added to the table that should have the following values:

» Linear Step. This type-of-sweep setting can also be selected from the
Distribution drop-down list.

¢ 0.0in the Start box.
¢ 0.04 in the End box.
* 0.005s in the Step size box.

6. Click OK.
7. Click File > Save to save the model before running the analysis.

Validate Design

Before running a simulation, it is best to validate its setup.

1. From the Maxwell 3D menu, select Validate Check. Alternatively, from the Simulation

tab, click the Validate icon.
2. Address any issues reported in the Validate Check window.

Run the Analysis

To run the analysis:
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¢ Right-click Analysis in the Project Manager tree, and select Analyze in the shortcut
menu. The time required to complete the analysis depends upon the speed and memory
capability of your machine and other applications that may be using machine resources.
The status of the simulation is reported in the Progress bar.
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6 - Postprocessing the Results

In this chapter you will complete the following tasks:

» Plot the magnetic flux density vector
¢ Plot the current density distribution

¢ Plot the torque versus time

* Plot the current versus time

Plot the Magnetic Flux Density Vector

This section describes how to plot the flux density vector on the mid-vertical symmetry plane of
the device. You previously set up a relative coordinate system (CS1) containing the desired plot
plane, so now you will do the following:

* Create an Object Selection
¢ Plot the Quantity

Create an Object Selection

Of particular interest are the results in the two armatures, so to plot only those results, create a
list of these two objects to prepare for the plot:

1. Select the Outer_arm and Inner_arm objects in the Modeler tree.
2. Click Modeler > Named Selection > Create > Object Selection.

The list of selected objects (ObjectSelection1) is added under Named Selections in the
Modeler tree.

Plot the Quantity

To create the plot:
1. Change the rendering of both Outer_arm and Inner_arm to wireframe by clicking View >
Render > Wire Frame.
2. Inthe Modeler tree, select the RelativeCS1:XY plane under Planes.
3. Inthe Project Manager tree, right-click Field Overlays, and select Fields >B > B_
Vector.
The Create Field Plot dialog box appears.

4. Make sure B_Vector is selected in the Quantity list.
5. Select ObjectSelection1 in the In Volume list.
6. Click Done.
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7. The B_Vector plot is displayed as shown below. The vector values are zero at 0 sec as a
result of the pulse source used in the winding setup having zero initial voltage.
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Set the Solution Context

To change the time step for post processing:

1. Click View > Set Solution Context or double click on the time context display in the
modeler window.

The Set View Context dialog box appears.

2. Select the Setup1:Transient from the Solution Name drop-down list.
3. Set the time step from the Time drop-down menu to 40 ms.
4. Click OK. The plot automatically updates to the new time as shown.
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5. Right-click on B_Vector1 in the Project Manager tree, and select Plot Visibility to turn off
the plot.

6. Setthe Solution Context back to 0s.

Plot the Current Density Distribution

To plot the current density distribution on the same XY plane of CS1 (RelativeCS1:XY):

1. Select the RelativeCS1:XY plane.
2. Right-click in the Modeler window, and select Fields > J > Mag_J from the shortcut menu.

The Create Field Plot dialog box appears.

3. Select Outer_arm from the In Volume List.
4. Click Done to plot.
5. Setthe Solution Context to 40 ms.

The field partially penetrates the stator, and the transient distribution of the current density
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shows significant skin effects.
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Plot Torque and Current

An important transient analysis feature is the ability to vary global quantities as a function of time.
Examples of such quantities include currents and voltages, power loss, torque/force, flux linkage
of windings, and induced voltages.

Create a Torque vs. Time Plot

To create a plot of the torque as a function of time:

1.

o bk~ b

Right-click Results in the Project Manager tree, and select Create Transient Report >
Rectangular Plot.

The Traces dialog box appears.

From the Solution drop-down menu, select the solution setup (Setup1).
From the Category list, select Torque.

Click the New Report button.

Click Close to dismiss the dialog box.
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Create a Current vs. Time Plot

To create a plot of the current as a function of time:

1. Right-click Results in the Project Manager tree, and select Create Transient Report >
Rectangular Plot.

The Traces dialog box appears.

From the Solution drop-down menu, select the solution setup (Setup1).
From the Category list, select Winding.

From the Quantity list, select Current.

Click the New Report button.

o bk~ DN
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6. Click Close to display the dismiss the dialog box.
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Close the Plot

To close the open plot:

» Click the X in the upper right corner of the plot window.

Note: After you close a plot, it is still available to view later, listed under Results in the

Project Manager tree.
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7 - Including Motion in the Simulation

In order to include the effects of motion of the Inner_arm, the object must be isolated from the
rest of the model using a mesh band. In order to create this mesh band, you will add two objects,
between the Inner_arm and Outer_arm objects.

In general, any moving object must be isolated from the stationary model using a mesh band.
For more information, see Meshing and Band Setting Recommendations for 3D Transient
Applications with Motion.

In this chapter, you will complete the following tasks:

« Add large motion to the simulation
¢ Analyze the transient solution with motion
» Post process the transient results
» Close the project and exit Maxwell

Create a New Model

Before adding motion to the design, save the “without motion” (or non-transient) design and
create a copy.

To save and copy the design:

1. Click File > Save to save the design.

2. Inthe Project Manager tree, right-click the Rotational_Act_TR design listed under the
project, and select Copy.

3. Inthe Project Manager tree, right-click the name of the project (also Rotational_Act_TR),
and select Paste.

A second copy of the same design appears under the single project; by default, the name
of the new design is Rotational_Act_TR1.

4. Double-click Rotational_Act_TR1 to make it active.

Add a Band Object to the Design

The band object is a regular polyhedron positioned so that it contains all rotating objects inside it.
To add the band object:
1. Set the working coordinate system to CS1:

Click Modeler > Coordinate System > Set Working CS, select RelativeCS1, and click
Select.
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2. Create aregular polyhedron around the Z axis named band:
a. Click Draw > Regular Polyhedron.
b. Type (0, 0, -121) in the (X, Y, Z) boxes, for the origin, and then press Enter.
c. Type (52.5, 0, 0) in the (dX, dY, dZ) boxes, for the radius, and press Enter.
d. Type (0, 0, 242) in the (dX, dY, dZ) boxes, for the height, and press Enter.

The Segment number dialog box appears.

e. Type 24 in the Number of segments text box.
f. Click OK.

The Properties window appears.

g. Click the Attribute tab.
h. Change the Name to Band.
i. Verify that Band is assigned the material property of vacuum (which should be the
default).
A polyhedron object named Band is drawn.

3. Create a cylinder named Air_rotor with the following properties:
a. Click Draw > Cylinder.

The cursor changes to a small black box, indicating that you are in Drawing mode.
b. Enterthe center of the cylinder base by typing (0,0,-120) in the (X, Y, Z) boxes at

the bottom of the screen, and press Enter.

c. Type 51.05 for the radius in the dX box at the bottom of the screen, and press
Enter.

Type 240 for the height in the dZ box, and press Enter.
In the Properties window, Click the Attribute tab.
Change the Name to Air_rotor.

Q@ -0 2

Verify that Air_rotor is assigned the material property of vacuum (which should be
the default).

A cylinder named Air_rotor is drawn.

The band and rotor geometry are shown below:
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Assign Motion to the Band Object

The circumference of the Band object falls between the inner armature and the outer armature
and contains inside it the Air_rotor and Inner_arm objects.

To assign motion to the Band object:

1. Right click on the Band from the Model\Solids entry in the history tree and select Assign
Band.

The Motion Setup dialog box appears.

From the Type tab, select Rotation as the Motion Type.

Set the Rotation Axis to Global:Z and select the Negative radio button.
Click the Mechanical tab.

Select the Consider Mechanical Transient check box.

Type 0.0024 in the Moment of Inertia field.

Enter 0.015 in the Damping field.

Click OK.

Apply Meshing to the Band Object

To apply the appropriate mesh operation to the band object:

© N o o bk 0w
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1. Right click the Band object underneath the Model\Solids entry in the history tree, and
select Assign Mesh Operation > Inside Selection > Length Based.

The Element Length Based Refinement dialog box appears.

2. Enter 20 in the Set maximum element length field, and select mm as the units.
3. Click OK.

Now you are ready to start the analysis with the effect of large motion included.

Set Up the Transient Analysis

To set up a second analysis:

Right-click Analysis in the Project Manager tree, and select Add Solution Setup.
In the Solve Setup dialog box, click the General tab.

Type 0.9 in the Stop time box, and select s as the unit.

Type 0.005 in the Time step box, and select s as the unit.

o~ b=

Add a sweep:
a. Click the Save Fields tab.
b. Select Custom. A row is added to the table that should have the following values:

« Linear Step. This type-of-sweep setting can also be selected from the
Distribution drop-down menu.

e 0.0in the Start box.

¢ 0.9inthe End box.

e 0.005 in the Step size box.
6. Click OK.

Run the Transient Analysis
To run the analysis:

Under Analysis in the Project Manager tree, right-click Setup2, and select Analyze.

Note: This simulation will take several minutes; the exact simulation time will depend
on your computer resources.

Postprocess the Transient Results

For the transient case, additional mechanical quantities are available (to represent as 2D plots
as functions of time), which were not available before adding motion to the design. When you
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create a report for a solution that is set to Transient, these new quantities can be added as
traces:

¢ Create a Position vs. Time Plot

¢ Create a Current vs. Time Plot with Motion

» Create a Torque vs. Time Plot with Motion

e Create a Power Loss vs. Time Plot

Create a Position vs. Time Plot

To create a plot of the position as a function of time:

1.

o~ b

Right-click Results in the Project Manager tree, and select Create Transient Report >
Rectangular Plot.

The Traces dialog box appears.

From the Solution drop-down menu, select the solution setup (Setup2).
From the Category list, select Position.

Click the New Report button.

Leave the Traces dialog box open.
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Current vs. Time Plot with Motion

To create a plot of the current as a function of time:
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1. Right-click Results in the Project Manager tree, and select Create Transient Report >
Rectangular Plot.
2. From the Solution drop-down menu, select the solution setup (Setup2).
3. Inthe Traces dialog box, from the Category list, select Winding.
4. From the Quantity list, select Current.
5. Click the New Report button.
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Torque vs. Time Plot with Motion

To create a plot of the torque as a function of time:

1. Inthe Traces dialog box, from the Category list, select Torque.
2. From the Quantity list, select Moving1.Torque.
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3.

Click the New Report button.
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Create a Power Loss vs. Time Plot

To create a plot of the eddy current power loss in the Inner_Arm and Outer_Arm as a function
of time:

AP owbd-=

In the Traces dialog box, from the Category list, select Loss.
From the Quantity list, select Solid Loss.

Click the New Report button.

Click Close to dismiss the dialog box.
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Getting Started with Maxwell®: Transient Problem

8 - Close the Project and EXxit Electronics
Desktop

Congratulations! You have successfully completed his Getting Started with Maxwell: Transient
Problem! You may close the project and exit the Ansys Electronics Desktop software.

1. Click File > Save to save the project.

2. Click File > Close.

3. Click File > Exit to exit Electronics Desktop.
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